I have an older post where I talk about mapping SAN volumes to a Linux host, and on how to identify the volumes that were created on the array.
In this post I will show how to identify a volumes created on a Storwize V7000 Storage Array on the AIX host.
From the Storwize V7000 GUI we can see that I created 1 volume. Volume test_UID with UID 60050768027F0001F00000000000016C was created, the volume was then mapped to an AIX host.
On the AIX host run the lspv command this will list the current volumes available on the host. If you don't see the newly created volumes, run the cfgmgr command from the command line. Next run the lspv command, and you will see the two new volumes that were created and mapped onto the host.
Running the lsattr command on the AIX host as shown below will show lots of information about the LUN, including the unique_id 3321360050768027F0001F00000000000016C04214503IBMfcp
From highlighted part of the unique_id 3321360050768027F0001F00000000000016C04214503IBMfcp
field we can find that this LUN maps to the the newly created volume on the storage array.
We can use the below script to show all the UID of the luns on the AIX host
In this post I will show how to identify a volumes created on a Storwize V7000 Storage Array on the AIX host.
On the AIX host run the lspv command this will list the current volumes available on the host. If you don't see the newly created volumes, run the cfgmgr command from the command line. Next run the lspv command, and you will see the two new volumes that were created and mapped onto the host.
isvp14_ora> lspv hdisk0 00f62a6b98742dad rootvg active hdisk59 00f62a6bf28975ed swapa active hdisk230 none None |
Running the lsattr command on the AIX host as shown below will show lots of information about the LUN, including the unique_id 3321360050768027F0001F00000000000016C04214503IBMfcp
From highlighted part of the unique_id 3321360050768027F0001F00000000000016C04214503IBMfcp
field we can find that this LUN maps to the the newly created volume on the storage array.
isvp14_ora> lsattr -El hdisk229 PCM PCM/friend/fcpother Path Control Module False algorithm fail_over Algorithm True clr_q no Device CLEARS its Queue on error True dist_err_pcnt 0 Distributed Error Percentage True dist_tw_width 50 Distributed Error Sample Time True hcheck_cmd test_unit_rdy Health Check Command True hcheck_interval 60 Health Check Interval True hcheck_mode nonactive Health Check Mode True location Location Label True lun_id 0x14000000000000 Logical Unit Number ID False lun_reset_spt yes LUN Reset Supported True max_retry_delay 60 Maximum Quiesce Time True max_transfer 0x40000 Maximum TRANSFER Size True node_name 0x50050768020000d2 FC Node Name False pvid none Physical volume identifier False q_err yes Use QERR bit True q_type simple Queuing TYPE True queue_depth 8 Queue DEPTH True reassign_to 120 REASSIGN time out value True reserve_policy single_path Reserve Policy True rw_timeout 30 READ/WRITE time out value True scsi_id 0x10900 SCSI ID False start_timeout 60 START unit time out value True unique_id 3321360050768027F0001F00000000000016C04214503IBMfcp Unique device identifier False ww_name 0x50050768022000d2 FC World Wide Name False |
We can use the below script to show all the UID of the luns on the AIX host
#!/usr/ksh for disk in $(lsdev -Cc disk|awk '{print $1}') do echo $disk: lsattr -EHl $disk -a unique_id echo --------------------------------------- done |
No comments:
Post a Comment