I've been mainly a Linux and Solaris guy for most of my tech career, and now I finally have a chance to tinker
around with AIX, AIX 7.1 to be precise.
Ok, so lets see what uname gives us here. As you see it tells us the OS name, version, and that we are on
a powerpc system
Next, how about telling us the amount of physical memory on this system. rmss with the -p flag tells us that we have around 24 GB of Memory that has been allocated to this system/LPAR.
list of the hardware configuration. Wow!!! this is actually pretty detailed, and handy information to have about
the system that we are working on.
How about some information on the disks and the file systems mounted. Let me try out good old df command. Lets see what it brings back.
To mount a filesystem in Solaris you would make an entry into /etc/vfstab , and in RedHat Linux into /etc/fstab.
The non of these file exist in AIX, out here it's dome through the /etc/filesystems file. Lets see what it has.
I won't cut paste the whole thing, but it has someting like this.
How about some disk information, something like fdisk -l in Linux, and format in Solaris. Out in AIX land the command is lspv. Ok, so let try it out. Well, I would like some more information that that. Let me look to see if there are any flags that can give me a bit more detailed information. Looks like the -p give us
more info, but it's very different to what I'm used to in Linux and Solaris.
around with AIX, AIX 7.1 to be precise.
AIX Version 7 Copyright IBM Corporation, 1982, 2010. login: root root's Password: ******************************************************************************* * * * * * Welcome to AIX Version 7.1! * * * * * * Please see the README file in /usr/lpp/bos for information pertinent to * * this release of the AIX Operating System. * * * * * ******************************************************************************* Last login: Fri Jan 21 11:01:47 MST 2011 on /dev/vty0 AIX Level is: 7.1.0.0 isvp17>Yay!!! that wasn't that hard.
Ok, so lets see what uname gives us here. As you see it tells us the OS name, version, and that we are on
a powerpc system
isvp17> uname -ap AIX isvp17 1 7 00F65D514C00 powerpc
Next, how about telling us the amount of physical memory on this system. rmss with the -p flag tells us that we have around 24 GB of Memory that has been allocated to this system/LPAR.
isvp17> rmss -p Simulated memory size is 24576 Mb.I would also like to know if this a LPAR or if it's a fully allocated system. prtconf will give me a detailed
list of the hardware configuration. Wow!!! this is actually pretty detailed, and handy information to have about
the system that we are working on.
isvp17> prtconf System Model: IBM,8233-E8B Machine Serial Number: 065D51P Processor Type: PowerPC_POWER7 Processor Implementation Mode: POWER 7 Processor Version: PV_7_Compat Number Of Processors: 6 Processor Clock Speed: 3000 MHz CPU Type: 64-bit Kernel Type: 64-bit LPAR Info: 1 isvp17 Memory Size: 24576 MB Good Memory Size: 24576 MB Platform Firmware level: AL710_099 Firmware Version: IBM,AL710_099 Console Login: enable Auto Restart: true Full Core: false Network Information Host Name: isvp17.storage.tucson.ibm.com IP Address: x.xx.xx.xx Sub Netmask: 255.255.254.0 Gateway: x.xx.xx.x Name Server: Domain Name: Paging Space Information Total Paging Space: 512MB Percent Used: 3% Volume Groups Information ============================================================================== rootvg: PV_NAME PV STATE TOTAL PPs FREE PPs FREE DISTRIBUTION hdisk0 active 559 454 111..97..22..112..112 ============================================================================== INSTALLED RESOURCE LIST The following resources are installed on the machine. +/- = Added or deleted from Resource List. * = Diagnostic support not available. Model Architecture: chrp Model Implementation: Multiple Processor, PCI bus + sys0 System Object + sysplanar0 System Planar * vio0 Virtual I/O Bus * ent1 U8233.E8B.065D51P-V1-C3-T1 Virtual I/O Ethernet Adapter (l-lan) * vscsi0 U8233.E8B.065D51P-V1-C2-T1 Virtual SCSI Client Adapter * hdisk0 U8233.E8B.065D51P-V1-C2-T1-L8100000000000000 Virtual SCSI Disk Drive * vsa0 U8233.E8B.065D51P-V1-C0 LPAR Virtual Serial Adapter * vty0 U8233.E8B.065D51P-V1-C0-L0 Asynchronous Terminal + fcs0 U8233.E8B.065D51P-V1-C36-T1 Virtual Fibre Channel Client Adapter + fscsi0 U8233.E8B.065D51P-V1-C36-T1 FC SCSI I/O Controller Protocol Device * lhea0 U78A0.001.DNWK129-P1 Logical Host Ethernet Adapter (l-hea) + ent0 U78A0.001.DNWK129-P1-C6-T1 Logical Host Ethernet Port (lp-hea) + L2cache0 L2 Cache + mem0 Memory + proc0 Processor + proc4 Processor + proc8 Processor + proc12 Processor + proc16 Processor + proc20 Processor isvp17>
How about some information on the disks and the file systems mounted. Let me try out good old df command. Lets see what it brings back.
isvp17> df -m Filesystem MB blocks Free %Used Iused %Iused Mounted on /dev/hd4 512.00 330.74 36% 9749 12% / /dev/hd2 16896.00 15105.72 11% 43011 2% /usr /dev/hd9var 512.00 245.90 52% 5684 10% /var /dev/hd3 3584.00 3581.45 1% 36 1% /tmp /dev/hd1 256.00 255.54 1% 17 1% /home /dev/hd11admin 256.00 255.62 1% 5 1% /admin /proc - - - - - /proc /dev/hd10opt 512.00 336.88 35% 7007 9% /opt /dev/livedump 256.00 255.64 1% 4 1% /var/adm/ras/livedump vanhalen:/vanhalen/tools 512.00 486.43 5% 541 1% /testlab/tools
To mount a filesystem in Solaris you would make an entry into /etc/vfstab , and in RedHat Linux into /etc/fstab.
The non of these file exist in AIX, out here it's dome through the /etc/filesystems file. Lets see what it has.
I won't cut paste the whole thing, but it has someting like this.
isvp17> cat /etc/filesystems * This version of /etc/filesystems assumes that only the root file system * is created and ready. As new file systems are added, change the check, * mount, free, log, vol and vfs entries for the appropriate stanza. * /: dev = /dev/hd4 vfs = jfs2 log = /dev/hd8 mount = automatic check = false type = bootfs vol = root free = true /home: dev = /dev/hd1 vfs = jfs2 log = /dev/hd8 mount = true check = true vol = /home free = false /usr: dev = /dev/hd2 vfs = jfs2 log = /dev/hd8 mount = automatic check = false type = bootfs vol = /usr free = false
How about some disk information, something like fdisk -l in Linux, and format in Solaris. Out in AIX land the command is lspv. Ok, so let try it out. Well, I would like some more information that that. Let me look to see if there are any flags that can give me a bit more detailed information. Looks like the -p give us
more info, but it's very different to what I'm used to in Linux and Solaris.
isvp17> lspv hdisk0 00f65d51a5aa3cf1 rootvg active isvp17> lspv -p hdisk0 hdisk0: PP RANGE STATE REGION LV NAME TYPE MOUNT POINT 1-1 used outer edge hd5 boot N/A 2-112 free outer edge 113-114 used outer middle hd6 paging N/A 115-126 used outer middle lg_dumplv sysdump N/A 127-127 used outer middle livedump jfs2 /var/adm/ras/livedump 128-224 free outer middle 225-225 used center hd8 jfs2log N/A 226-226 used center hd4 jfs2 / 227-230 used center hd2 jfs2 /usr 231-231 used center hd9var jfs2 /var 232-232 used center hd3 jfs2 /tmp 233-233 used center hd1 jfs2 /home 234-234 used center hd10opt jfs2 /opt 235-235 used center hd11admin jfs2 /admin 236-236 used center hd4 jfs2 / 237-240 used center hd2 jfs2 /usr 241-241 used center hd9var jfs2 /var 242-242 used center hd10opt jfs2 /opt 243-243 used center hd3 jfs2 /tmp 244-301 used center hd2 jfs2 /usr 302-313 used center hd3 jfs2 /tmp 314-335 free center 336-447 free inner middle 448-559 free inner edge isvp17> isvp17> lspv -l hdisk0 hdisk0: LV NAME LPs PPs DISTRIBUTION MOUNT POINT hd3 14 14 00..00..14..00..00 /tmp hd9var 2 2 00..00..02..00..00 /var hd2 66 66 00..00..66..00..00 /usr hd4 2 2 00..00..02..00..00 / hd10opt 2 2 00..00..02..00..00 /opt hd1 1 1 00..00..01..00..00 /home hd8 1 1 00..00..01..00..00 N/A hd6 2 2 00..02..00..00..00 N/A hd5 1 1 01..00..00..00..00 N/A lg_dumplv 12 12 00..12..00..00..00 N/A livedump 1 1 00..01..00..00..00 /var/adm/ras/livedump hd11admin 1 1 00..00..01..00..00 /admin
1 comment:
Great reading your blog poost
Post a Comment